Discussion:
e la shell scazza...
(too old to reply)
francesco
2002-11-26 03:13:25 UTC
Permalink
Un fenomeno succede da quando ho installato la debian, e ora vorrei risolvere.
Quando succede qualcosa in X (ad esempio si carica kde oppure si scarica la
posta con kmail, oppure cambia l'mp3 riprodotto nella playlist di xmms,
insomma ogni volta che KDE "fa qualcosa di non minimizzato") la console
(framebuffer matrox) "scazza" nel senso sembra si blocchi o fa apparire linee
strane (in realta' si blocca solo la visualizzazione), e per farla tornare
"normale" devo fare una specie di "refresh" (se così si puo' chiamare il
passare ad un'altra console e poi tornare a quella). Suggerimenti?

- --
Francesco
Marco
2002-11-28 21:56:06 UTC
Permalink
On Tue, 26 Nov 2002 04:13:25 +0100
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Io sospetto che la tua scheda video abbia un difetto hardware.
Hai provato anche con altro gestore di finestre per vedere se si ripropone un effetto simile???

Ciao
Un fenomeno succede da quando ho installato la debian, e ora vorrei risolvere.
Quando succede qualcosa in X (ad esempio si carica kde oppure si scarica la
posta con kmail, oppure cambia l'mp3 riprodotto nella playlist di xmms,
insomma ogni volta che KDE "fa qualcosa di non minimizzato") la console
(framebuffer matrox) "scazza" nel senso sembra si blocchi o fa apparire linee
strane (in realta' si blocca solo la visualizzazione), e per farla tornare
"normale" devo fare una specie di "refresh" (se così si puo' chiamare il
passare ad un'altra console e poi tornare a quella). Suggerimenti?
- --
Francesco
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.0 (GNU/Linux)
iD8DBQE94ubZLD8KrT/l9LQRAlZpAJ9Ckvek3N33xvEcGfwBu+kb0E0gbwCeIIPJ
PBb+7+O9t7JnC8HN/I2kkxY=
=W8X7
-----END PGP SIGNATURE-----
--
francesco
2002-11-29 01:56:56 UTC
Permalink
Post by Marco
Io sospetto che la tua scheda video abbia un difetto hardware.
Hai provato anche con altro gestore di finestre per vedere se si ripropone
un effetto simile???
Ciao
Post by francesco
Un fenomeno succede da quando ho installato la debian, e ora vorrei
risolvere. Quando succede qualcosa in X (ad esempio si carica kde oppure
si scarica la posta con kmail, oppure cambia l'mp3 riprodotto nella
playlist di xmms, insomma ogni volta che KDE "fa qualcosa di non
minimizzato") la console (framebuffer matrox) "scazza" nel senso sembra
si blocchi o fa apparire linee strane (in realta' si blocca solo la
visualizzazione), e per farla tornare "normale" devo fare una specie di
"refresh" (se così si puo' chiamare il passare ad un'altra console e poi
tornare a quella). Suggerimenti?
succede anche con gnome2, e se non ricordo male succede anche a un mio amico a
cui ho installato la debian, e lui ha una geforce 2.
l'unica idea che mi e' venuta e' che potesse avere a che fare con gpm, provo e
riposto...

- --
Francesco
francesco
2002-11-29 07:43:07 UTC
Permalink
Post by francesco
Post by francesco
Un fenomeno succede da quando ho installato la debian, e ora vorrei
risolvere. Quando succede qualcosa in X (ad esempio si carica kde
oppure si scarica la posta con kmail, oppure cambia l'mp3 riprodotto
nella playlist di xmms, insomma ogni volta che KDE "fa qualcosa di non
minimizzato") la console (framebuffer matrox) "scazza" nel senso sembra
si blocchi o fa apparire linee strane (in realta' si blocca solo la
visualizzazione), e per farla tornare "normale" devo fare una specie di
"refresh" (se così si puo' chiamare il passare ad un'altra console e
poi tornare a quella). Suggerimenti?
succede anche con gnome2, e se non ricordo male succede anche a un mio
amico a cui ho installato la debian, e lui ha una geforce 2.
l'unica idea che mi e' venuta e' che potesse avere a che fare con gpm,
provo e riposto...
come non detto, il problema persiste anche fermando gpm, e anche con wm.
aiuto!

- --
Francesco
adri
2002-12-01 14:40:39 UTC
Permalink
il giorno Fri, Nov 29, 2002 at 08:43:07AM +0100, francesco ha scritto
Post by francesco
come non detto, il problema persiste anche fermando gpm, e anche con wm.
aiuto!
anche io ho una matrox g400 su di un pentium 3 e lo stesso problema ce
l'ho anch'io...
pensavo che fosse un problema del kde3, perche' a me e' successo quando
sono passato a quella major release, ma se mi dici che lo fa anche con
gnome2...
purtroppo non ho mai avuto molto tempo per indagare, ma quasi quasi,
adesso che hai lanciato il sasso...
toglimi una curiosita': quando fai il refresh (passi in un'altra
console, poi ritorni) ti capita di doverla rifare dopo un po' perche' lo
schermo "ri-salta"?
ciao
adri
--
icq# 63011800 - jabber: ***@jabber.org
gnupg key id: 1C66B3DE
"Non esiste vento favorevole per il marinaio che non sa dove andare."
Seneca
francesco
2002-12-01 16:42:31 UTC
Permalink
Post by adri
anche io ho una matrox g400 su di un pentium 3 e lo stesso problema ce
l'ho anch'io...
pensavo che fosse un problema del kde3, perche' a me e' successo quando
sono passato a quella major release, ma se mi dici che lo fa anche con
gnome2...
purtroppo non ho mai avuto molto tempo per indagare, ma quasi quasi,
adesso che hai lanciato il sasso...
toglimi una curiosita': quando fai il refresh (passi in un'altra
console, poi ritorni) ti capita di doverla rifare dopo un po' perche' lo
schermo "ri-salta"?
ciao
adri
si, ad esempio se uso la console mentre in X ho xmms con una lista di canzoni,
inevitabilmente al cambio di canzone lo schermo risalta, ed e' necessario un
nuovo "refresh". ho messo un framebuffer 960x720x16 (per capirci, in lilo ho
append="video=matrox:vesa:0x18A"). grazie per l'aiuto, unendo le forze ce la
potremmo fare :)

ciao

- --
Francesco
Lo'oRiS il Kabukimono
2002-12-01 22:59:31 UTC
Permalink
Post by francesco
framebuffer matrox
innanzitutto disabilita il cursore hardware da X, se non l'hai già fatto
--
"Un deja-vu!" - "Veramente a casa mia si chiamano GATTI"
- Lorenzo Petrone
. /\ °
Real Name: Lorenzo Petrone <* >
WEB!!! http://lano.webhop.net \/ ·
francesco
2002-12-02 02:01:35 UTC
Permalink
Post by Lo'oRiS il Kabukimono
innanzitutto disabilita il cursore hardware da X, se non l'hai già fatto
come scusa? non penso di aver capito...

- --
Francesco
Lo'oRiS il Kabukimono
2002-12-02 17:07:30 UTC
Permalink
Post by francesco
come scusa? non penso di aver capito...
un impostazione del file di configurazione di X ti permette di disabilitare
il "cursore hardware". Ecco, fallo, dato che alcune matrox hanno dei
problemi al riguardo. Non ricordo di preciso, ma te la dovresti cavare con
una breve ricerca su google. Oppure prova (vado a memoria) a mettere nella
sezione del mouse
hwcursor "off"
--
"There are very few personal problems that cannot be solved
through a suitable application of high explosives"
. /\ °
Real Name: Lorenzo Petrone <* >
WEB!!! http://lano.webhop.net \/ ·
francesco
2002-12-02 22:10:15 UTC
Permalink
Post by Lo'oRiS il Kabukimono
un impostazione del file di configurazione di X ti permette di disabilitare
il "cursore hardware". Ecco, fallo, dato che alcune matrox hanno dei
problemi al riguardo. Non ricordo di preciso, ma te la dovresti cavare con
una breve ricerca su google. Oppure prova (vado a memoria) a mettere nella
sezione del mouse
hwcursor "off"
ho provato a mettere la riga Option "HWCursor" "off" ovunque dentro a
XF86Config-4 ma il risultato non cambia, grazie comunque.
continuero' le mie ricerche.

- --
Francesco

Continue reading on narkive:
Loading...